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1 Introduction 

The Option System add-on feature of Vertex BD software allows the design of buildings 

with optional structures and optional materials in one integrated building model and 

database. It manages architectural, construction, and material information. It also 

produces the construction documentation required for construction and manufacturing 

of optionalized buildings. 

Once the base model and the options have been designed and defined, the graphical 

representation of the different design alternatives can be created. The options selected 

will be automatically incorporated into the floor plans, elevations, 3D models, framing 

plans, panel drawings and other required documentation. Material lists are automatically 

updated reflecting the correct material quantities and costs for the specific selected 

option combination. 

About This Manual 

This user manual will guide you through the basic steps for defining, adding and solving 

options of a building. The user manual presumes that you have the basic knowledge of 

using Vertex BD software. The key features of Option System are briefly described, 

followed by an example of how the functions are applied to a project design. You can 

find instructions of all the features of the Option System in Vertex BD Help. Open the 

help file in either of the following ways: 

• Select  Help from the menu bar. 

• You can open the help for an individual function from the button menus. Move the 

cursor over the button, and hold shift while clicking the left mouse button to open the 

help. 
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Understanding and Using Options 

The options method enables you to create variations within a project. This means that 

you can easily create additional unique models from a single project. An option may be 

as simple as substituting a dishwasher for a cabinet, adding a decorative trim package, 

or adding a fireplace. An option may also be as complex as adding a three-car garage, 

changing the exterior material on the front elevation and changing windows, or adding a 

wet bar sink and changing a bedroom into a library or study. 

The possible options for a project are defined in the Options database. The database 
contains information about the options, like option id, name and description. After this, 

the option is designed in the floor plan drawing or in the model by modifying the building 
components. To solve an option correctly, all drawing-model pairs that are affected by 
the option must be modified. In other words, if a fireplace is added as an option, the 

foundation, first floor plan, first floor deck, second floor plan, second floor deck, and roof 
drawing-model pairs should have an option reflecting the changes that will be made. 

 

To create a variation of the building, the desired options are selected and the options are 
solved. When the options are solved for the full project, a new set of job-specific drawings 
are created. The base drawings, and any secondary option drawings, are left intact so 

additional options can be created. 

Overview of the User Interface 

When the Option System add-on feature is included in your software, you can open the 

Option System function menu by clicking the Options tab on the ribbon bar. 
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Note: You can check the available software add-on features by selecting File > This 

Software Version from the ribbon bar. The add-on features included in the software 

will be displayed in a message box. 

Design Process 

When you design options, follow these main steps: 

1 Define the options in the options database. 

2 Cut the links between objects, for example cut walls. 

3 Define the options on the drawing by selecting building components. 

4 Design the new option by changing the configuration of the building components. 

5 Select the building components to be added to the option or to be removed from the 

option. 

6 Verify the defined option by activating it in the active drawing-model pair, or in all 

drawing-model pairs at once. 
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7 Solve the entire model with the desired options. 

8 Restore the original model. 

Details of these steps are described in the following chapters. In each chapter the 

functions are are applied to an example project design.  
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Basic Concepts of Options 

The figure below explains some basic option system concepts used in this user manual. 

 

=   Locating point of an option Option box 

Option fence 

Option Id Option condition, for example 

Sub option box 



 

VERTEX BD OPTION SYSTEM GUIDE 10 

2 Options Database 

The Options database describes all of the options that are a part of the project. Each 

option that is to be solved must be listed in the database. You may have more options in 

the Options database than are used in the project; however, this may confuse other 

users who may try to solve for a specific option that is not defined on the plan. Only 

options that are defined on the plan will be solved. 

You can use the template projects to set up the option information. Define an option 
database for each template project you use for creating new projects. After you have 

created a new project, you can modify the option database of the project by adding or 
deleting items. The Options database is stored with the project so the same option names 
can be used in multiple projects.  
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Opening the Options database 

Open the Options database in the following way: 

1 In the Options tab, select Project Options >   Project Options. 

The Project Options database view opens. There may be options already available 
for a new project if the option information has been set up in the template project that 
has been used to create the project. Below is an example of a template Options 

database. 

 

The parameters on the database view are: 

• Option Number - Used to sort and organize the option list, its number must be 

unique. 

• Option Name - This is the key field. It is the name of the Option and will be 

displayed on the drawing (16-character limit). It is also what is used to identify the 

option when the option is added, edited, or solved. 

• Description – Option description. 
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Adding Items into the Options Database 

Before adding an option to the floor plan of the project, the option must be defined in the 
Options database. You may add options to the database at any time, even when you are 

adding options to the floor plan. Add an option to the Options database as follows: 

1 In the Project Options database view, move to the location where you want to add 

the item and do one of the following: 

• Right Click > Copy Row or press Ctrl+Shift+Insert. This will copy the line where 

the cursor was located. 

• Right Click > Add Row Before or press Shift+Insert. This will add a new line 

above the line where the cursor was located. 

• Right Click > Add Row After or press Alt+Shift+Insert. This will add a new line 

below the line where the cursor was located. 

2 Fill in the fields Option Name and Description in one of the following ways: 

• Select one of the following from the ID list: 

Option Name Explanation 

header A header does not define a true option. You can use the 

header alternative to define a group of options. Define the 

header as the main level of options and then define sub 

options under the header. 

default The default option for the structure or the components. 

reverse_building An option which mirrors the building or a drawing in 

relation to a user defined axis. 

Type a description in the Description field. 

• Type a desired label in the Option Name field. Allowed characters in the Option 

Name are the letters a-z and A-Z, numbers 0-9 and the special character 

underscore (_). Do not use the following character strings within the body of the 

Option Name: or, and, not. For example "motorrm". Type a description in the 

Description field. 

3 Type the number of the option in the Option Number field. 
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Removing Items from the Options Database 

To delete an option from the Options database, do the following: 

1 In the Project Options database view, move the cursor to the row that you want to 

delete. 

2 Right Click > Delete Row or press Shift+Delete. You will receive the prompt: 

Delete row? 

 

3 Select Yes and the row will be deleted. 

While you are active in the current database, any additional deletions will be 

immediate; you will not be prompted each time. 

Saving or Quitting the Database 

To save the database, click the OK button in the database view. All the changes you 

made will be saved and you will exit the database. To quit without saving the changes, 

press the Esc key or click Cancel. You will then be prompted to save the changes. 

Select No and you will exit the database and the changes will not be saved.  
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Example Project 

In the following chapters of this guide, you will learn how to use the options functions by 

examples. The example project used in this guide is a simple one-storey building. The 

floor plan of the example building is shown in the figure below. Create a new project 

based on a regular template project and add the building components to the following 

drawing-model pairs: 

• Add the walls and dimensions to the 1st Level, Wall Layout drawing-model pair. 

• Add the foundation walls to the Foundation or Basement drawing-model pair. 

• Add the floor to the 1st Level, Deck Layout drawing-model pair. 

• Add the gable roof to the Roof drawing-model pair. Stretch the wall sidings to the 

roof. 

Select the wall, window and doors types as you prefer.  

 

Creating the Options Database of Example Project 

In the example project, you will create an Options database of your own. If the project 

template you used includes an Options database template, you can delete all the items 



OPTIONS DATABASE 

VERTEX BD OPTION SYSTEM GUIDE 15 

in the database and define new ones. Use the procedures described earlier to open the 

database, delete lines and add new lines.  

1 Open the Options database. 

2 Delete all the lines in the database, if there are any. 

3 Add new lines to the database and fill in the data as shown in the database view 

below. 

 

The line 1 header does not define an option but it is a header line which defines the 

front elevation as the component for which options are created. 

The option 1.1 default defines the default shape of the front elevation which in this 

example is a straight wall. 

The options 1.2 eleva and 1.3 elevb are the options for the front elevation. 

The option 1.2 eleva has two sub options, the 1.2.1 default and 1.2.2 windows 

(elevation with extra windows). 

You will learn more about these options and create new ones in the following 

chapters. 

4 Click OK to save the database and to close the database view.  
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3 Adding Options to the Floor 

Plan 

You may add as many options to a floor plan as needed. You may have more options in 

the options database than are used in the project, but only options that are defined on 

the plan will be solved. 

One of the major features of options is to create optional elevation conditions that you 
can use to create a number of different styles. For the project example, you will create 

an elevation with various modifications.  
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Adding an Option to the Plan 

1 Load in the appropriate drawing-model pair for the option addition. For this example, 

open the 1st Level, Wall Layout drawing-model pair. 

2 In the Options tab, select   New. 

3 You can control which objects will be selected with a filter tool. Click the  

Selection Filter button on the toolbar. 

By default, all element types are selected in the Selection Filter dialog box. For this 
example, select the element types Dimensions, Walls, Exterior and Walls, Interior 

and clear other selections. 

 

4 Select all objects that you wish to add to the option. Hold down the Ctrl key while 

clicking the objects. In the example project, select the following walls and the 

dimensions. 

 

To avoid selecting the entire length of the vertical walls, you can use the Cut Wall 

function before creating the option. Click on the wall you want to cut, select Cut 

Wall, and then select where you want the cut to be made. 

5 Select the Confirm function. 

6 Select the origin point, or the point that you will use as a locating point for the option. 

Select a point that will not interfere with any other option location. In the example 
project, click the point shown in the figure below. 
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The system will add an origin point symbol to the selected location. The Option 

Condition for Components in Option Box dialog box opens. 

 

In the dialog box, you can use three operators to define conditions for options: 

• And - The option on the floor plan will only apply if options A and B are both 

selected to be solved. 

• Or - The option on the floor plan will only apply if option A or option B is selected 

to be solved. 

• Not - The option on the floor plan will only apply if option A is selected and option 

B is not selected to be solved. 

At this point, you don’t have to use any of these operators. You will use the Or 

operator later in the example project when defining a sub option. 

The objects you have cut before defining the options will be merged during the option 

solving process when you select the appropriate check boxes. By default, all check 
boxes (Walls, Floors, ceilings and roofs and Rooms) are selected. 

By selecting the Hide all components in option check box the system will hide the 

2D/3D geometry of the options and improve the speed of the system. In this 

example, leave the check box blank. 
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7 To select the options from the Options database, click the Select button in the 

dialog box. The Project Options database view opens. 

8 Move the cursor on the line 1.2 eleva and click OK. 

 

The Option Condition for Components in Option Box dialog box opens again. 

9 Click OK in the dialog box. 

 

10 Select the location for the option box. Zoom out the drawing by pressing the F7 key, 

for example. You can lock the cursor in the x or y axis direction, in which case the 

cursor is locked to move through the selected locating point. Place the option box 

far enough away from the floor plan drawing that it will not interfere with the current 

plan's notes and dimensions. 
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The program copies the walls and dimensions you selected to the Default option 

box. You can now edit the walls and dimensions on the floor plan drawing to create 

the elevation option. 

11 Select  Zoom Extents from the toolbar or press Shift+A. 

The options can be anywhere in the drawing area. The next figure shows another 

example of a floor plan drawing where there are 15 options defined in one drawing. 

Each option has a fence around it and is far enough away from the original base plan 

that notes and dimensions can be added. 
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Note: You may have hidden the layer to which the option box geometry is added if you 

have activated a layer group while creating the floor plan. If the option boxes are not 
visible in the floor plan drawing, select all layers as visible by going to the View tab and 
selecting Layers > All Layers, for example. 

Editing the Option 

After you have added the option definition to the floor plan, you can modify the walls and 

other components to design the optional elevation. 

Editing the Configuration of the Components 

In the example project, change the wall layout by adding, deleting and trimming walls. 

The result is shown below. 

 

To create the example elevation, follow these steps: 

1 Add the new walls with the  Wall function. 
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2 Cut the original front wall with the  Cut Wall function. Cut the wall at two points. 

3 Delete the extra part of the front wall. 

4 Form corner joints with the  Joint >   Corner Connection function. 

5 Add a door and two windows of your choice. 

6 Add new dimensions. 

Adding Components to the Option 

After designing the elevation, add the components you have inserted to the defined 

option condition. In the example project, add the extra walls to the eleva option 

condition. 

1 In the Options tab, select  Edit. 

2 Select the eleva option box. 

 

The option box and all objects associated to the option become highlighted in green. 

3 Select the walls and the dimensions you have added. Hold down the Ctrl key while 

clicking the components. 

 

4 Select the Confirm function. 

5 Press Esc to quit the function. 
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Activating an Option 

Now you have two options for the front elevation: the default option and the eleva 

option. Switch the default option active in the following way: 

1 In the Options tab, select  Activate.   

2 Select the option you want to activate. 

 

3 Select the Confirm function. 

The default option is activated. The components of the eleva option are moved to 

the eleva option box.  
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Editing the Option Box Size 

Edit the eleva option box size to fit in all the components of the option. 

1 In the Options tab, select  Size. 

2 Select the option box. 

 

3 Select the edge to be moved. 

 

4 Select the new location. 

 

5 Quit by pressing the Esc key. 

Copying an Option 

In the example project, create another elevation option by copying the eleva option. 

1 In the Options tab, select   Copy. 

2 Select the option box. 



ADDING OPTIONS TO THE FLOOR PLAN 

VERTEX BD OPTION SYSTEM GUIDE 25 

 

The Option Condition for Components in Option Box dialog box opens. 

3 Click the Select button in the dialog box. 

 

The Project Options database view opens. 

4 Move the cursor on the line 1.3 elevb and click OK. 
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5 Click OK in the Option Condition for Components in Option Box dialog box. 

 

6 Select the location for the option box. Zoom out the drawing by pressing the F7 key, 

for example. Place the option box far enough away from the floor plan drawing. 

 

The program moves the components of the default option to the default option box, 

and copies the components of the eleva option to the floor plan. 

You can now edit the floor plan drawing to create the elevb option. 
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Editing the Copied Option 

In the example project, edit the elevation by changing the window and door types. You 

can change the opening type in the following way: 

1 Quit the previous function by pressing the Esc key. 

2 Select an opening. 

3 Right-click to open the context-sensitive menu. 

4 Select Properties. The Window or Door dialog box opens and you can select 

another opening. 

Move the openings on the floor plan, if necessary. Add new dimensions. 

 

When the option is ready, add the components to the option. In this example, the edited 

windows and the door are still included in the option, as only the type of the openings 

was changed. However, new dimensions must be added to the option. 

1 In the Options tab, select  Edit. 

2 Select the elevb option box. 

 

The option box and all the objects associated to the option become highlighted in 

green. 

3 Select the dimensions to be added to the option condition. Hold down the Ctrl key 

and click the dimension lines. 

4 Select the Confirm function. 
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Creating a Sub Option 

If you want to create an optional elevation by just modifying a part of an existing 

elevation option, you can do it by creating a sub option. 

In the example project, you will create a sub option for the eleva option. First make sure 

that one of the other options, default or elevb, is activated, and all the components of 

eleva option are in the eleva option box. Edit the components in the eleva option box. 

Before defining the sub option, cut the walls in the eleva option box as shown in the 

figure below. 

 

It is also a good idea to group the dimensions together before defining the sub option. 

You can do this by selecting all of the dimensions in the option, right clicking, and 

selecting Advanced > Create Group. 

 

Defining the Sub Option Condition 

Define the sub option in the following way: 

1 In the Options tab, select  New. 
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2 Select the walls. Hold down the Ctrl key while clicking. 

 

3 Select the Confirm function. 

4 Select the origin point. Click the point shown in the following figure. 

 

The Option Condition for Components in Option Box dialog box opens. 

5 Click the Select button in the dialog box. 
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The Project Options database view opens. 

6 Move the cursor on the line 1.2.2 windows and click OK. 

 

7 Click OK in the Option Condition for Components in Option Box dialog box. 

 
8 Select the location for the option box. Zoom out the drawing by pressing the F7 key, 

for example. 
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The program copies the selected walls to the default sub option box. If necessary, 

re-add any dimensions that got moved from the eleva option box to the Default sub 

option box. 
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You can now edit the walls in the eleva option box to design the windows sub 

option.  
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Editing the Configuration of the Sub Option 

In the example project, add two windows to the windows sub option. Edit the walls in 

the eleva option box. 

 

Use the  Edit function to add the components to the windows option. 

Editing Other Drawing-Model Pairs 

To solve an option correctly, all drawing-model pairs that are affected by the option must 

be modified. In the example project, you will add an option to the Foundation, 1st Level 

Deck Layout and Roof drawing-model pairs reflecting the changes made in the 1st Level 
Wall Layuot drawing-model pair. 

Editing the Foundation 

As the wall layout of the elevation options eleva and elevb are alike, you can use the 

same foundation option for both elevations. 

Before you start, make sure the elevation option eleva or elevb is active in the 1st Floor 

Walls drawing-model pair. 

1 Open the Foundation drawing-model pair. Press F4 and select  Foundation from 
the button menu. The 1st floor walls should be visible as a reference drawing in the 
drawing window. 
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2 Cut the front wall of the foundation at the approximate points shown in the figure 
below. After you have solved the options, the walls will merge so the cut lines will 
not be visible. 

 

3 In the Options tab, select  New 

4 Select this part of the foundation wall. 

 

 

5 Select the Confirm function. 

6 Select the origin point. Click the point shown in the next figure. 

 

The Option Condition for Components in Option Box dialog box opens. 

7 Click the Select button in the dialog box. 
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The Project Options database view opens. 

8 Move the cursor on the line 1.2 eleva and click OK. 

 

9 In the Option Condition for Components in Option Box dialog, select the radio button 

Or, and click the Select button again. 

 

The Project Options database view opens again. 

10 Move the cursor on the line 1.3 elevb and click OK. 
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11 Click OK in the Option Condition for Components in Option Box dialog box. 

 

12 Select the location for the option box. 
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13 Edit the foundation walls according to the elevation options of the 1st floor. 

 

14  In the Options tab, select  Edit 

15 Select the eleva or elevb option box. 

 

16 Select the walls you want to add to the option. 

 

17 Select the Confirm function.  
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Editing the Floor 

Open the drawing-model pair of the 1st Level Deck Layout and create a floor option you 

can use for both eleva and elevb elevation options. Use the Or operator when setting 

the option conditions as you did in the Foundation drawing-model pair. 

You can create the floor option by cutting the floor into two areas, and add just the 

smaller area to the option. Edit the area by moving its edge. When you solve the 

options, the areas will be merged. 

 

Click on the floor and select the Clip   function in the Plane Structure tab to cut the 

floor area. Select the smaller floor section and move the edge until it matches the 

outline of the house 

 

 

Editing the Roof 

Open the Roof drawing-model pair and create an option you can use for both eleva and 

elevb elevation options. When creating the roof option, it is not necessary to cut the links 
between the walls and the roof. 

Before you start designing the roof option, make sure that either of the elevation options 

eleva or elevb is activated in the drawing-model pair of the 1st floor walls. 



ADDING OPTIONS TO THE FLOOR PLAN 

VERTEX BD OPTION SYSTEM GUIDE 39 

When you create a new option, select both slopes of the default roof to be included in the 
option. When you set the option conditions, use the Or operator as you did in the 
Foundation drawing-model pair. 

Add the crossing roof according to the walls of the elevation option eleva or elevb, and 

add the new slopes to the option by editing the option components. 

 default option box eleva or elevb option box 

 

Add the crossing roof and combine it with the slope of the main roof 

Activating All Options With the Same Name 

After you have modified all the drawing-model pairs, check the options to ensure that 
they work correctly. You can easily activate all options with the same name in all 

drawingmodel pairs as follows: 

1 In the Options tab, select  New >  Test. The Select Options list opens. 

2 Select the options to be processed by selecting the check box in front of the option 

number. For example, select the option 1.2 Front elevation option A and its sub 

option 1.2.2 Elevation A with extra windows. 

 

3 Click OK. The selected options will be activated in all drawing-model pairs.  
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Stretching Wall Exterior Sidings to the Roof 

Activate the model window, and check the stretching of wall exterior sidings to the roof. 

Activate each option in turns as described before, and check the stretching of exterior 

sidings to the option roof in the model window. 

1 Select the wall, right click, and select  Stretch to Roof. 

2 Select the roof slopes to which the sidings will be stretched. 

 

3 Select the Confirm function. The Stretch Wall Layer to Roof dialog box opens. 

4 Select the radio button Top in the dialog box, and click OK. 

 

When you first created the building and stretched the walls to the default roof, the 

program created a link between the walls and the roof. To enable the correct stretching 

of the walls when you solve the options, you will need to connect the gable and side 

walls also to the option roof. Stretch the walls to all the four roof slopes as shown in the 

next figure. 

Note: The side walls have been cut. Stretch the cut walls as well. 
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Moving Option Boxes And Components Inside Them 

You can move the option boxes and the components inside the boxes to place the 

options with the same option condition on top of each other in different drawing-model 

pairs. 

Moving the Option Box 

1 Activate the default structure to move the option components to the option boxes.  

In the Options tab, select  New >  Test, and select the option 1.1 Straight 

wall as the option to be processed. 

2 Open the Foundation drawing-model pair. The 1st floor walls should be visible as a 

reference drawing in the drawing window. 

3 In the Options tab, select  Size. 

4 Click the edge of the option fence around the option boxes to move all the option 

boxes of the structure in question. 

 

5 Click the snap point in the middle of the fence. 

 

6 Select the new location. Place the option fence approximately on the corresponding 

fence in the reference drawing. 
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7 Press the Esc key to quit the function. 

During the next steps, you will move the components exactly on top of the components 

in the reference drawing. 

Moving the Components Inside the Box 

1 Select  Option System >  Move Origin in Option Box. 

2 Select the option box. 

 

3 Click the REFPOINT button above the status bar. If you cannot see the button, 

stretch down the bottom edge of the Vertex window.  

 

4 Select the reference point for the components to be moved. 

 
5 Select the new location. Select a point of the reference drawing. 
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6 Press Esc to quit the function.  



ADDING OPTIONS TO THE FLOOR PLAN 

VERTEX BD OPTION SYSTEM GUIDE 44 

Optional Opening Trims 

If you want to have several opening trim alternatives, you don’t have to define a new 
elevation option for each trim type. You can add one trim type to the openings in the 

building model, and then define the other alternatives in the following way: 

1 Open the 1st Level Wall Layout drawing-model pair and activate the 3D model 

window. 

2 In the Options tab, select  New >   Edit Option Data. 

3 Select a window. You can only select one window at a time. The Option Conditions 

for Opening Trims dialog box opens. 

4 Click the Select button in the dialog box. 

 

The Project Options database view opens. 

5 Add 3 new lines to the database and fill in the following data: 

Order ID Name 

2 header Opening trim options 

2.1 trim1 Opening trim option 1 

2.2 trim2 Opening trim option 2 

The database view should now look like this: 
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6 Move the cursor on the line 2.1 trim1 and click OK. The Option Conditions for 

Opening Trims dialog box opens again. 

7 Select a trim set from the Values drop-down list. 

 

8 To define another optional trim set, click the New button in the dialog box. The fields 

in the dialog will be cleared. 

9 Click the Select button. The Project Options database view opens. 

10 Move the cursor on the line 2.2 trim 2 and click OK. 

11 Select another trim set from the Values drop-down list. 

12 Click OK in the Option Conditions for Opening Trims dialog box. 

Repeat the procedure to all the openings you want to add optional trims. The window 

may be located in the original model or in one of the option boxes. You can later change 

the trim sets you selected with the same editing tool. 
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Note: The optional trims will be added to the openings when you solve the option. 

Note: You can use the same method to define different wall type alternatives for an 

elevation option.  
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Editing the Option Id 

You can edit the option information at any time during the design process. In the example 
project, change the option ID of the default front elevation. First change the ID in the 

Options database, and then refresh the ID in the floor plan. 

1 In the Options tab, select Project Options >   Project Options. 

2 Move the cursor on the line 1.1 default and change the ID to basic. 

 

3 Click OK in the Project Options database view. 

Note: In order for the option to work correctly after the ID has been changed, be 

sure to perform the following steps: 

4 Inthe Options tab, select  New >   Edit Option Data  

5 Select the Default elevation option box. 

 

6 The Option Condition for Components in Option Box dialog box opens. 

7 Select the text Default and press Delete. 
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8 Click the Select button in the dialog box. The Project Options database view opens. 

9 Move the cursor on the line 1.1 basic and click OK. 

10 Click OK in the Option Condition for Components in Option Box dialog box. 

 

11 The ID is refreshed in the floor plan drawing. 

 



ADDING OPTIONS TO THE FLOOR PLAN 

VERTEX BD OPTION SYSTEM GUIDE 49 

Defining Option Rules 

When you test or solve the options of the building, you select the options to be processed 
from the Select Options list. All the available options for the project are displayed in the 

list. On the list, there may be options which cannot be selected at the same time with 
another option, or options which require another option to be processed at the same time. 

You can control the selection of options by defining option rules. 

Rule Option ID Exclude/Include Result when selecting the options 

Exclude A B If you select option A, option B 

becomes automatically deselected. 

Include A B If you select option A, option B 

becomes automatically selected. 

Set the option rules for the example project in the following way: 

1 In the Options tab, select Project Options >   Option Rules. The Structural 

Option Rules database view opens. The template database is empty. 

2 Add a line to the database by pressing Shift+Insert. The default value in the Rule 

field is E = Exclude. 
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3 Click the Select button above the Option ID field. The Project Options database 

view opens. 

4 Move the cursor on the line 1.1 basic and click OK. 

5 Click the Select button above the Exclude/Include field. The Project Options 

database view opens again. 

6 Move the cursor on the line 1.2 eleva and click OK. 

7 Repeat the procedure for as many rules to be set. You can set following rules, for 

example: 

 

8 Click OK to save and close the database.  



ADDING OPTIONS TO THE FLOOR PLAN 

VERTEX BD OPTION SYSTEM GUIDE 51 

Stretching a Building 

Using the options function, you can stretch a single plan or the whole building in the X 

axis or Y axis direction. 

Define the stretch option to the example building in the following way: 

1 In the Options tab, select Stretch >  Define. 

2 Select the corner points of the area you want to stretch. 

 

Note: When you solve the stretch option, the dimensions will be refreshed even 

if the dimension lines were left outside the stretch area. 

3 Select the Confirm function. The Option Condition for Components on Stretch Area 

opens. 

4 Click the Select button in the dialog box. The Project Options database view opens. 

5 Add a line to the database and fill in the following information: 
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6 Click OK in the database view. The Option Condition for Components on Stretch 

Area opens again. 

7 Enter the stretching dimension in the dialog box. In this example, you will stretch the 

building in the x axis direction. Enter the dimension in the Dx field. To apply the 

change to all drawing-model pairs of the building, select the check box Stretch in 

all floors. If the area to be stretched includes sloping horizontal structures, you can 

select whether the structure is stretched in the horizontal direction or in the sloping 

direction. In this example, the stretching direction is insignificant, and you can use 

either of the options. 
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8 Click OK in the dialog box. The building will be stretched when you solve the option, 

see "Solving the Whole Building" on page 59. 

Note: The stretch option will not be processed when you use the Test Options 

function, see "Activating All Options With the Same Name" on page 40.  
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Reversing a Building 

Using the options function, you can reverse the whole building. The building is mirrored 

about a user defined axis. All components, including wall panels, are mirrored. 

Defining the Mirroring Line 

Define two points by which the building model will be mirrored. 

1 In the Options tab, select Mirror Line >  Define  

2 Select the start and end points of the mirroring line. 

 

3 The Option Condition for Reverse Building opens. Click the Select button in the 

dialog box. 
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4 Add a line to the database and fill in the option data.

 
 Note: Select reverse_building from the ID list. 

 

5 Click OK in the database view and the Option Condition dialog box. The building 

will be mirrored when you solve the option, see "Solving the Whole Building" on 

page 59. 

6 Hide and show the location of reversal axis with the Mirror Line > Toggle 

function. 

Note: The reverse_building option will not be processed when you use the 

Test Options function, see "Activating All Options With the Same Name" on page 

40. 
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4 Solving Options 

Once you have defined and designed all options, you can create different design 

alternatives of the building by solving the options. You can create a job specific drawing 

set for each solved building. You can also create a construction document set to 

indicate all of the options available for the particular project.  
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Solving the Whole Building 

In the previous chapter you learned how to check the options by activating all options 

with the same name, see "Activating All Options With the Same Name" on page 40. 

Once all options work correctly you can solve for the entire building. 

When you solve the whole building the system will store and deactivate the original 

model and drawing files of the project. After solving the options, you can restore the 

option model and create and solve additional options. 

Note: It is always a good idea to save your project prior to solving the entire building. 

To solve the whole building, follow these steps: 

1 In the Options tab, select Solve >  Solve. The Select Options list opens. 

2 For the example project, select the following options: 

• 1.2 Front Elevation option A 

• 1.2.2 Elevation A with extra windows 

Select the check boxes of these options on the list. 

 

3 Click OK to confirm. You will receive the prompt: 
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When you solve the whole building, you can create the job specific floor plan, 

elevation, section etc. drawings of the solved building. The drawing sheets to be 

generated are the same drawing sheets you can create and refresh with the  

Drawing Sheets function in the Output tab.  

4 Click Yes to create the job specific drawing set. 

The program solves the options and refreshes the model and drawing files of the 
building. Once the process is complete, the system remains in the solved model. You 

can check the status of the project from the title bar of the working window. 

 

You can open the drawing sheets with the  Drawing Sheets function. 

Note: You can also optionalize the drawing sheets for different options, see 

"Optionalizing Drawing Sheets" on page 62.  
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Restoring Option Model 

When you solve the whole building the system deactivates the original model and 

drawing files of the project. You can restore the option model with the Restore Option 

Model function. After you have restored the option model, you can no longer view the 

drawing sheets of the solved model. 

1 In the Options tab, select  Restore . You will receive the prompt: 

 

2 Confirm the restoring of the model by clicking Yes in the appearing message box.  

You can check the status of the project from the title bar of the working window. 
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Optionalizing Drawing Sheets 

You can edit the elevation views of the building by adding basic geometry elements like 

texts or lines to the drawing, for example. However, these elements are not connected 

to the building and won’t be mirrored when you solve the reverse_building option. 

Therefore, you need to optionalize the elevation view drawings. In the next example, a 

ground level line is added to an elevation view drawing. The ground level line is 

optionalized for the reverse_building option by mirroring the line. 

The template elevation views are usually empty drawings. Before adding the ground 

level line to the elevation views, the elevation view drawing files need to be updated 

according to the building model. 

Updating the Elevation Views 

Make sure you are in the Option Model status.You can check the status of the project 

from the title bar of the working window. 

1 In the Output tab, select  Drawings >  Update Views. The View Tasks dialog 

box opens. 

2 Select the check box Update views, and clear the check box Update models. The 

program will now use the drawing generation model created in the option solving 
process to generate the elevation views. Select all the elevation views in the Views 

list. Hold down the Ctrl key while clicking the view names. 
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3 Click OK in the View Tasks dialog box. The elevation view drawings open in 

separate drawing windows. 

Adding the Ground Level Line 

1 Activate one of the elevation view drawings, for example the ELEV-R. 

 

2 In the Drafting tab, select  Lines >  Polyline. 

3 Select the properties of the line from the drop-down lists on the contextual tool bar. 

 

Note: If you want to add a ground level line which cuts and either dashes or 

hides the lines of the foundation below the ground level, add the line on the layer 93 

Dashing Ground Line or 94 Clipping Ground Line.  

4 Add the line to the elevation view drawing. 
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 5 Press Esc to quit the function. 

Adding an option to the view drawing 

First, create a geometry group of the ground level line, and add it to the option. 

1 Select the line. 

2 Right-click to open the context-sensitive menu. 

3 Select Advanced> Create Group. 

4 In the Options tab, select  New. 

5 Click the  Selection Filter, and make sure that the element type Groups of 

Geometry is selected. 
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6 Select the geometry group consisting of the ground level line. 

 

7 Select the Confirm function. 

8 Select the locating point. Select a point in the drawing. In the next figure, the 

intersection point of the foundation wall and the ground level line is selected. 

 

The Option Condition for Components in Option Box dialog box opens. 

9 Click the Select button in the dialog box. The Project Options database view opens. 

10 Move the cursor on the line 4 reverse_building and click OK. 
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The Option Condition for Components in Option Box dialog box opens again. 

11 Click OK to confirm. 

 
12 Select the location for the option box. If necessary, edit the option box size and 

location, see "Editing the Option Box Size" on page 26. 
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Editing the Option 

Edit the option by mirroring the ground level line in the elevation view drawing. 

1 Press Esc to quit the previous function. 

2 Select the line. 

 

3 Right-click to open the context-sensitive menu. 

4 Select Mirror from the menu. 

5 Select the start and end points of the mirroring line. 
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You will receive the prompt: "Maintain original geometry?" 

6 Click No in the message box. The ground level line is mirrored. 

 

7 Close the drawing file by clicking the Close button of the drawing window. You will 

receive the prompt: “Save changes?” 

8 Click Yes in the message box. 

Solving the Option and Viewing the Drawing Sheet 

When you solve the options and select the reverse_building option, the ground level 

line in the elevation view drawing will also be mirrored. 

1 Solve the options like described before, see "Solving the Whole Building" on page 

59. Select the options Front elevation option A and Reverse building to be 

solved, for example. Select Yes when the program prompts you to create the job 

specific drawing set. 

2 In the Output tab, select  Drawing Sheets. The View Tasks dialog box opens. 

3 Clear the check boxes Update views and Update models. These tasks were 

already performed when you solved the options and created the drawing set. Select 
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one of the elevation drawings sheets in the Sheets list, for example res-b-

02elev.vxp. 

 

4 Click OK in the dialog box. The elevation drawing sheet is opened and you can see 

the mirrored ground level line in the edited elevation view. 

 

Creating a Master Set 

In addition to the job specific document set, you can create a drawing set which will 

indicate all of the options and their combinations available for the particular project. This 

master set can be used to submit to a governing agency for approval, for example. 

An option combination consists of option groups that you select for presolving before 

creating a master set. Each option group can contain several options. You can have an 
option combination presolved whenever you want, and then add the completed drawings 

to the master sets. 

In the next example, you will create an elevation drawing with all the different front 

elevation alternatives of the example project placed on the same drawing sheet. 
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Note: Presolving options is available when the Master Sets add-on feature is included 

in your software.  
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Defining Option Groups 

You can create an option group from individual options. When you select an option 

group to be solved, all the options in the group will be solved. You can use the global 

option groups in all projects. The basic delivery of the software includes an example of 

an option group database. The database can be customized to meet the requirements 

of your company. In this example, you will create an option group for the different 

elevation alternatives. 

1 In the Options tab, select Project Options >  Global Option Groups. The 
Global Option Groups database view opens, and the Options of Group database 

view is displayed below it. 

 

The option group database should always include the BASE option group, which is 

the base model of the building. 

2 Add a line to the Global Option Groups database, and fill in the data of ELA group 

as shown in the next figure. 
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An option group can include several options, but in this example, just one option is 

defined for the ELA option group. 

3 Define another option group ELB in the same way. 
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4 Close the database views by clicking OK. 

Note: You can select an option from the Master database by clicking the Master (select 
one option) or Select (select several options at once) button in the Options of Group 

database view. 

Creating a New Drawing Sheet 

Create a drawing sheet for the different elevation alternatives. 

1 In the Options tab, select  Master Set. The Master Set Drawings database view 

opens. 

2 Click the New button in the database view. 
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3 Select the template sheet. Select the B size sheet b-sht.vxp, for example. 

 

4 Type the sheet name in the text box. 

 

Note: Type the name without the extension .vxp. The program will automatically 

name the drawing sheet as EF_Options_1.vxp. 

5 Fill in the other information about the drawing. 
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6 Click OK in the database view. 

The database view is closed and the drawing sheet EF_Options_1.vxp remains 

open in the work space.  
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Setting Up Option Configurations 

Define the option groups to be solved and the drawings to be created from them. 

1 In the Options tab, select  Master Set >   Set Up Option Configurations. 

The Set Up Option Configurations dialog box opens. 

 

2 Click the Add Group button in the dialog box. The Select Group to Add selection list 

opens. 

3 Select the option groups ELA and ELB you defined earlier from the list. Scroll down 

the list, if necessary. 
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4 Click OK to return to the Set Up Option Configurations dialog box. 

5 Select all the option groups to be solved by selecting the check boxes in the Option 

Groups list. 

 

6 For each option group, select the drawings that will be created when the options are 

solved. Select the drawings in the Group Drawings and Settings list. In this example, 
select at least the FRONT ELEVATION for each group. 
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7 Click OK to save the settings and close the dialog box. 

Solving the Options 

After selecting the option groups to be solved and the drawings to be created from them, 

you can start solving an option configuration. If the option configuration contains several 
option groups with several options to be solved, solving them may take some time. You 
can leave the program to solve the option groups overnight, for example. 

1 In the Options tab, select  Master Set >  Solve and Update. You will receive 

the prompt: Solve and update master set drawings? 

 

2 Select Yes in the message box. The program solves the options and creates the 

selected drawings. The program creates a subfolder in the project's MS folder 

according to the name of the option group. The drawings will be saved in this folder. 

The solved model remains active. 

Note: You can restore the option model by selecting  Restore in the Options tab.  
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Opening a Drawing Sheet 

Open the drawing sheet you created earlier. 

1 In the Options tab, select  Master Set. The Master Set Drawings database view 

opens. 

2 If the drawing sheet you created is not on the first row of the database, use the 

cursor keys to move to the right row. 

3 Click the Open button in the database view. 

 

The drawing sheet opens in the work space. 

4 Click OK or Cancel to close the database view. 

Adding an Optionalized Drawing on Sheet 

After the option groups have been solved, you can add the drawings created from the 

solved model to master set drawing sheets. 

1 In the Options tab, select  Master Set >  Add Drawing on Sheet. The Select 

Drawing dialog box opens. 

2 Select the option group Base House and the drawing FRONT ELEVATION in the 

dialog box. 
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3 Click OK in the dialog box. 

4 Before selecting the location of the view, change the scale of the view. Right click 

and select the  Scale button. 

5 Select the scale 1/16”, for example. 

 

6 Select the location of the elevation view on the sheet. 
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The Select Drawing dialog box opens again. 

7 Repeat the procedure for as many elevation alternatives you want to add to the 

drawing sheet. In the figure below, the front elevations of option groups Elevation A 

and Elevation B have been added to the drawing sheet in addition to the base 

elevation. You can also add other drawings to the sheet, for example the floor plan 

drawings of the different options. 
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8 After you have added all the desired views on the drawing sheet, click the Cancel 

button in the dialog box. 

9 Select File > Save to save the drawing and close the drawing sheet by clicking the 

Close button of the drawing window. 

Note: If you want to delete a view from the open drawing sheet, select  Reference 

Drawings >  Delete from the toolbar and select the view you wish to delete. 

Comparing Bills of Materials 

Once you have solved the entire building with the desired options, you can collect the 

materials and create the bill of materials in the usual way, i.e. using the functions in the 

 Material Reports menu in the Output tab. 

In addition to this, the Option System add-on feature includes the functionality to 

compare the material quantities between the default building and different sets of 

options. You can collect materials for each option group during presolving of options, 

and then select the option groups that you want to compare. 

Note: Presolving options is available when the Master Sets add-on feature is included 

in your software.  
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Collecting Materials when Presolving Option Groups 

You can collect materials for the differential bill of materials during option group solving. 

Collecting materials may increase the time required for solving. 

1 In the Options tab, select  Master Set >  Set Up Option Configurations. The 

Set Up Option Configurations dialog box opens. 

2 Select the Collect Materials for +/-BOM check box in the Group Drawings and 

Settings list for all the option groups that you want to collect materials from. 

 

3 Click OK to save the settings and close the dialog box. 

4 Solve the options with the  Master Set >  Solve and Update function, see 

"Solving the Options" on page 77. 

Defining the Option Groups to be Compared 

1 In the Options tab, select  +/-BOM Groups. 

The Option Groups for +/-BOM database view opens. By default, the database 

contains the option group BASE. This is the default building model to which the 

material quantities of other option groups can be compared. 
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The items on the database view are: 

• Status - The groups to be compared are marked with an X in the Status field. 

• Order - The order number is used to sort and organize the list of option groups. 

Each group must have a unique number. 

• Group Name - Label for the option group. 

• Description - Description of the option group. 

• Compare to Set - The Group Name of the option group you want the quantities 
to be compared to. Usually, the material quantities of option groups are compared 
to the BASE group. 

2 Click the Update button to add the presolved option groups to the database. They 

are automatically compared to the BASE group. 

 

3 Click OK in the Option Groups for ±BOM database view. 
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Printing the +-/BOM Report 

1 In the Options tab, select  Master Set >  Print ± Reports. 

2 Select the report to be printed from a list. 

 

The difference between these two reports is the output format of the bill of materials 
which is generated as a result of the comparison process. Both output formats can be 

customized to meet the requirements of your company. 

The so-called Differential bill of materials is opened in the default word processor. The 
material quantities of the option groups are compared to the default building model 

named BASE. The materials of the BASE group are displayed at the top of the list. 
The quantities of the other model groups are compared to the BASE set, and only the 
differences in the quantities are displayed on the list on behalf of these sets. 

You can edit, print and save the list with the functions of the word processor. 


